DIY Products

DIY Products

Whether you’re an experienced do-it-yourselfer or doing your own taxes for the first time, this is your place to learn and share. Here you’ll find information and resources for using H&R Block’s online and software DIY solutions. You’ll also find links to more information to assist you on your DIY journey.

Reply
Pioneer
Posts: 2
Registered: ‎02-18-2017

Windows XP SP3 compatability

Hi,
 I have windows XP (i know, i'm old:-(... and I filed my 2014 taxes a couple of months ago with the H&R Block Deluxe +efile+State  downloadable software. I'm ready to download the 2015 H&R block Deluxe software, but want to be sure it is compatable with XP SP3.

I called H&R Block's 800# customer service. The Rep said NO. Afterward, I registered & signed onto this community and found this:

What operating systems is the H&R Block tax software compatible with?

The Basic, Deluxe, and Premium versions of the H&R Block Tax Software offered for 2015 tax returns are compatible with the following operating systems (OS) and browsers:

Windows
    XP SP3 or Higher
    Vista®
    Windows 7
    Window 8.1
    Windows 10
    Internet Explorer® 8 or higher

The Premium & Business version is only compatable with the following operating systems and browsers:
Windows
    XP SP3 or Higher
    Vista®
    Windows 7
    Window 8.1
    Windows 10
    Internet Explorer® 8 or higher
 
My question is:

Is the 2015 Deluxe downloadable software compatable with Windows XP SP3 (like This Community states)?

and...

Since I have you'all here...

If so, Is the 2016 Deluxe downloadable software also compatable with XP SP3?

...in other words:

If XP SP3 has become incompatable, when did that start?

TIA
signed,
not a high confidence level from the 800# customer service

Tax Pro
Posts: 5,795
Registered: ‎02-23-2016

Re: Windows XP SP3 compatability

[ Edited ]

Hi taxcutcustomer2,

 

Welcome to the H&R Block community.

 

The 2016 software is definitely compatible.  The H&R Block software typically works with the latest version of Windows as of its release year and likewise for Macintosh users.

 

2015 should be compatible as well, but I'm not 100% certain on that one.  If there was a compatibility issue with the software last year that may be why they told you it wasn't compatible even though it was supposed to be.

 

If you have any other questions I'll be glad to help.

 

Louis,

Senior Tax Advisor (Tampa, FL)

Pioneer
Posts: 2
Registered: ‎02-18-2017

Re: Windows XP SP3 compatability

Hi LouisH,

 

'The 2016 software is definitely compatible.  The H&R Block software typically works with the latest version of Windows as of its release year and likewise for Macintosh users.'

 

You are talking about windows XP sp3, correct?  I'm not understanding why you would bring up 'the latest version of windows'.  If the H & R Block software didn't work with 'the latest version' no one would buy it.

 

I was talking about XP SP3 compatability for the 2015 & 2016 year release.

 

Your unclear answer is giving me about the same confidence level as the 800# customer service.

 

kudos

Pioneer
Posts: 1
Registered: ‎10-29-2017

Re: Windows XP SP3 compatability

is the 2017 pre order of h and r block tax software compatible with windows xp?

Tax Pro
Posts: 5,795
Registered: ‎02-23-2016

Re: Windows XP SP3 compatability

Hi,

 

 

This question comes up at least once every year, and the answer is that the H&R Block software is supposed to be compatible with all of the latest windows versions & likewise for MacIntosh.  Since we are all volunteers at the community level (even those of us who otherwise work for Block) I cannot give you an answer to this question with 100% certainty.  You might however try calling support at 1-800-HRBLOCK and asking to speak to a software support agent.  They might know for sure if it will work with your specific version of windows.

 

The best advice I can give you is to make sure you select the Windows version when you go to download the software upon its release.  You'll be able to select whether you need the windows software or the Macintosh software once the download becomes available.

Highlighted
Associate (Pioneer)
Posts: 9
Registered: ‎04-13-2017

Re: Windows XP SP3 compatability

The 2017 version of the software requires Windows Vista or newer.

- Matthew
Business Analyst, Kansas City, MO